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1 Before You Begin

1.1 Who Should Use This Manual
This manual is for system administrators responsible for installing, configuring and using
X32/X52 on a Linux system. This manual assumes knowledge of:

•  As a stand-alone program: the operating system Linux (SuSE 7.0 or equivalent Red Hat
version)

•  As an eLux plug-in: the Embedded Linux (eLux®) software

1.2 About This Guide
This documentation presents step-by-step directions on how to install, configure and use the
X32 – 3270 and X52 – 5250 emulations for Motif as either a stand-alone program or as a plug-
in on a Thin Client running eLux software. Information in this manual is valid for both stand-
alone and plug-in programs. When X32/X52 as a stand-alone program differs from X32/X52
as an eLux plug-in, this is noted.

Due to the widespread use of X32/X52 on Thin Clients running eLux, pictures are of the X32
emulation as an eLux plug-in. When the X52 emulation differs from X32 in appearance or
function, this is noted.

For convenience, the manual is divided into the following sections:

Chapter Description

1 Before You Begin Manual conventions, overview of X32/X52 functions and

features

2 Getting Started System requirements, detailed instructions on installing

and starting X32/X52

3 Licensing How to enter a license

4 Connections and Sessions Connecting and disconnecting sessions, setting

connection and session parameters

5 Programming Key Functions Programmable keys, user keys, keyboard mapping,

releasing IBM functions

6 X32/X52 Functionality Copy and paste, cursor options, color options, printing,

changing font size, saving data transfer to diagnosis files

1.3 Conventions and Abbreviations

Conventions
The following are text formats and symbols that appear in the manual:

Convention Description

! Refers to a procedure.

> Move to a menu.

“ ... “ Quotation marks refer to screen text and text in pop-up

dialog boxes.
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ALL UPPERCASE Represents keyboard keys (for example, ENTER, F4,

CTRL).

Bold Indicates boxes and buttons, column headings, dialog

box titles, lists, menu names and menu commands and

new terms.

Courier New The Courier New font represents entries you can type at

the command line and directory names.

<Italics> Indicate a placeholder for information or parameters that

you must enter. As an example, if the procedure asks you

to type <IP address>, you must type the actual IP

address. Italics can also refer to book titles.

Commonly-Used Abbreviations
The following are terms that appear in the manual:

Abbreviation Description

IP address Internet Protocol address. IP addresses are represented

in four 3-digit groups separated by periods.

Example: 192.45.85.1

TCP Transmission Control Protocol

1.4 Finding More Information
This manual contains conceptual information, installation and configuration instructions for
X32/X52 as a stand-alone program and as an eLux plug-in. Additional information is available
from the following sources:

•  The X32 – 3270 / X52 –- 5250 for Motif Administrator’s Guide for previous releases of X32
and X52

•  The eLux Administrator’s Guide for information on using X32/X52 as a plug-in with the
Thin Client software Embedded Linux (eLux ), which generates the configuration file
automatically

•  The Felics Administrator’s Guide for information on the license server

This guide as well as other X32/X52 documentation is available in Adobe PDF format. It can
be found in the following locations:

•  The documentation folder on your eLux CD-ROM

•  The product documentation library at www.myelux.com

1.5 X32/X52 on the World Wide Web
UniCon offers online technical support at www.unicon-ka.de. This includes the following:

•  PDF versions of the documentation

•  Downloadable software

•  The latest updates and hotfixes for download

•  A list of supported hardware

To access the site you must complete a one-time, free registration.
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1.6 Overview

What is X32/X52?
For everyone who wants to have a high-capacity UNIX workstation or an X terminal as a
multifunctional workplace, X32/X52 now offers easier and more comfortable access to
OS390/AS400. Our UNIX products can be used on all market-relevant UNIX systems.

•  X32 for Motif is a complete emulation of a connection independent 3270 terminal.

•  X52 for Motif is a complete emulation of a connection independent 5250 terminal.

This manual describes in detail how to configure and use the 3270/5250 emulations. Please
be aware that UniCon TCP/IP coupling products (currently X32, X52, X97) installed as stand-
alone programs require the Felics license server for dynamic licensing. (See section 2.2
Installation Procedure for information on installing Felics.)

X32/X52 Features
X32/X52 offer the following features:

•  Printing hard copies, local hard copies, screen shot or to file

•  20 programmable keys that can easily be managed using the P Key Editor

•  20 user-defined keys that can easily be managed using the B Key Editor

•  User-defined foreground and background colors

•  Status line displaying line status, transaction state and cursor position

•  System bar displaying connection name, time and connection state

•  One-step connection using a mouse click

•  Dynamic fonts

•  Saving data transfer files for diagnosis

•  Printing on a bypass line from an OS390 host
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2 Getting Started
This chapter contains the introductory information you need to get X32/X52 running.

Note This chapter contains installation information for X32/X52 as a stand-alone program. If you
are using the emulation as an eLux plug-in, skip to section 2.5.

Section Description

2.1 System Requirements Operating system requirements needed to run X32/X52

2.2 Installation Procedure Step-by-step instructions on how to extract X32/X52 from

x32.tar/x52.tar and the different files that will be installed

2.3 Removing How to remove X32/X52

2.4 Starting How to start X32/X52 using command-line parameters

2.5 Main Window A detailed description of the different screen elements

2.6 Closing How to close X32/X52
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2.1 System Requirements
X32/X52 has the following minimum system requirements:

•  Stand-alone: Linux operating system (SuSE 7.0 or higher, or Red Hat 7.0)
X11 server

•  Plug-in: Embedded eLux (eLux )

2.2 Installation Procedure
Note The following section describes the installation procedure for X32/X52 as a stand-alone
program. Installing X32/X52 as an eLux plug-in is done using the image definition file (*.idf).
See the eLux Administrator’s Guide and the Elias Administrator’s Guide for more details. If you
are using X32/X52 with eLux, please skip to section 2.5.

The installation file X32/X52 is available on the Internet. Download x32.tar/x52.tar from
www.unicon-ka.de (click on “Service”). You need a password to download software. To obtain
a password, please contact vertrieb@unicon-ka.de.

To install X32/X52, extract the archives on the root file system “/”. Example:

cd /

tar xvf /tmp/x32.tar (or the disk drive as installed on your machine)

After installation, all files are found in /usr/u97.

Connecting to the Felics License Server
If you have not yet installed the UniCon license server, install it now (see the Felics manual). It
is not included in the tar file. You must download it from www.unicon-ka.de (click on “Service”).
You need a password to download software. To obtain a password, please contact
vertrieb@unicon-ka.de.

Using the program /usr/felics/brandli (UNIX) or REMBRAND (Windows), enter the X32/X52
licenses you purchased.

Licensing information entered using Felics is valid for all UniCon terminal emulations (X32,
X52, X97).

2.3 Removing
Note The following section describes the removal procedure for X32/X52 as a stand-alone
program. Removing X32/X52 as an eLux plug-in is done using the image definition file (*.idf).
See the eLux Administrator’s Guide and the Elias Administrator’s Guide for more details.

To remove, delete all the installed files in /usr/u97 (see section 2.2, “Installation Procedure”).
Example:

cd /usr

rm –rf u97

2.4 Starting
Stand alone: Before starting X32/X52, check that the program directory of X32/X52 contains
the environment variable PATH (by default, /usr/u97/bin). The first time X32/X52 starts, the
directory .xemu is created in the user directory and the configuration files from the central data
directory (/usr/u97/data) are copied to .xemu. The following command line parameters can be
entered:

call: x32 -c <configuration file>

-c (optional) The name of a configuration file can be entered here. By default,
X32/X52 uses the configuration file 3270.cfg/5250.cfg in the directory
$HOME/.xemu (see section 4.1 Configuration File). Do not enter a path or add the
extension “.cfg” when calling a configuration file from the command line.

ELux plug-in: To start X32/X52 as an eLux plug-in, use the Configuration and Application
tabs of the eLux starter. See the eLux Administrator’s Guide for more information.
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2.5 Main Window
Starting X32/X52 displays the main window, which contains the following elements:

Title Bar
Displays the session name, if a session name has been set (see “Se
4.3 Session Parameters, page 17).

The two buttons in the right-hand corner adjust screen size. As a stan
minimize button  minimizes the screen. (As an eLux plug-in, the m
when the eLux taskbar is turned on in the eLux starter: Setup > Desk
screen width button  toggles between full screen and the font width

Main Menu

The main menu contains six menus: File, Edit, Keyboard, P Keys, A
open a menu, click with the mouse. To navigate using the keyboard, 
underlined letter - for example, ALT + F for “File“.

Keyboard Window

The keys displayed are a copy of the 3270/5250 terminal keyboard a
directly by clicking with the left mouse button. The keyboard is shown
Add-On > Keyboard window has been activated.

Worksheet
Click with the left mouse button to move the cursor to any position the
allows.

The NILS (array of dots) are shown if the menu command Add-On >
activated. The copy and paste feature is described in section 6.1 Cop

Main menu
Title bar
 Worksheet
s

n

 

Keyboard window
9

sion name” in section

d-alone program, the
inimize button works only
top > Taskbar.) The full
 set in fonts, page 28.

dd-On and ? Help. To
press ALT and the

d can be activated
 if the menu command

 application mask

Show NILS has been
y and Paste.

Status bar
System bar
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System time / Timer

Status Line

The status line displays the line status when connected to a host. In addition, it displays the
address of the cursor position (in the format: yyxx) if the menu command Add-On > Show
cursor position has been activated.

Status Line Symbol Meaning

Input locked by host, wait until next message from host

A host response is running

User error, press Reset

Caps lock

Insert

Shift

System Bar

Displays the product name, connection name, field mode (displayed for numerical fields) and
time (licensed products) or timer (for products that are not yet licensed). The color box shows
the state of the connection.

•  red no connection

•  yellow trying to connect

•  green connection established

Quick connect: Double-click using the left mouse button on the color box to connect or
disconnect.

2.6 Closing
To close X32/X52, use the file command File > Close or the keyboard equivalent ALT + 4.

ELux plug-in: Always close the emulation from within the application. Do not use the
Disconnect button in the eLux starter when connected to a host! The LU name remains
occupied!

Color boxConnection name

Line status Cursor position

Product name
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3 Licensing
X32/X52 is a licensed product that must be purchased. As a stand-alone program, licensing takes
place via the Felics license server. See section 2.2 Installation Procedure for more information.

This chapter describes the licensing procedure for X32/X52 as an eLux plug-in.

Section Description

3.1 Licensing Using the Scout eL

Management Tool

How to use the Scout eL management tool to enter an

X32/X52 license

3.2 Licensing at the Thin Client How to use the X32/X52 emulation to enter a license

server or a limited validity license key

3.3 No License How to use X32/X52 without a license for testing purposes
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3.1 Licensing Using the Scout eL Management Tool
If you use the Scout eL management tool, the easiest way to enter a license is using Scout eL.

Enter the X32/X52 license using Scout eL menu command: Options > License information.
(See the Scout eL Administrator’s Manual for step-by-step instructions on how to enter
licenses.) When using Scout eL, the license is automatically transferred to the emulation and
the X32/X52 menu command Add-On > Licensing is disabled.

3.2 Licensing at the Thin Client
To enter a license at the Thin Client, you must start the emulation. Open the License
Management dialog box using the X32/X52 menu command Add-On > Licensing.

Local Licensing
For testing purposes, you can obtain a license key from UniCon with limited validity. Enter the
local license key using the X32/X52 menu command Add-On > Licensing. The duration of
the testing period is displayed after “Valid” (dd.mm.yyyy).

License Server
If your organization uses a Felics license server, enter the license server name (or IP
address).

3.3 No License
X32/X52 is a licensed product that must be purchased. However, by default it can be used for
15 minutes with full functionality without a license for testing purposes. The 15 minutes begin
when you connect to a host. The time remaining is displayed in the status line (bottom right-
hand corner).

After 15 minutes, a message appears saying your time has expired. The status line changes
to red lettering on a black background for 30 seconds. This additional time is provided to allow
you to log off from the host before the emulation ends.

Local licensing
with license key

License server
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4 Connections and Sessions
This chapter describes the how to establish and end a connection, and the required session and
connection parameters.

Section Description

4.1 Configuration File A description of the configuration file (3270.cfg/5250.cfg),

and how to open and save.

4.2 Connection Parameters A detailed description of how to set connection parameters

(3270.tcp/5250.tcp).

4.3 Session Parameters A detailed description of how to set session parameters.

4.4 Connecting Mouse, menu and keyboard commands for establishing a

session.

4.5 Disconnecting Mouse, menu and keyboard commands for disconnecting

a session.
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Required path for
eLux plug-in!

4.1 Configuration File
X32/X52 administrates all session data in a configuration file. By default this is:

•  $HOME/.xemu/3270.cfg for X32 (stand alone)

•  $HOME/.xemu/5250.cfg for X52 (stand alone)

•  /setup/xemu/3270.cfg for X32 (eLux plug-in)

•  /setup/xemu/5250.cfg for X52 (eLux plug-in)

This allows you to customize the emulation’s appearance and behavior to your needs as well
as activate the start parameters. A configuration file must contain:

•  General session parameter

•  Link to a connection from the connection file. See 4.2 Connection Parameters

•  Link to programmable keys (for example, 3270.pt/5250.pt). See 5.1 Programmable Keys
(P Keys)

•  Link to user keys (for example, 3270.bt/5250.bt). See 5.2 User Keys (B Keys)

•  Link to a keyboard file (for example, 3270.kbd/5250.kbd). See 5.3 Keyboard Mapping

•  Link to a trimodal keyboard file (for example, 3270tri.kbd/5250tri.kbd). See 4.3 Session
Parameters, page 22.

•  Link to a color file (for example, 3270.frb/5250.frb). See 6.3 Colors

Open Configuration

The menu command
File > CONFIGURATION > Open
allows you to load a different
configuration file. Enter the path and
configuration file name in the Load
Configuration dialog box. When you
load a configuration file, existing
X32/X52 settings are deleted and any
existing connection is ended.

Stand-alone: The default path is
$HOME/.xemu.

ELux plug-in: The default path is
/setup/xemu. The path must be the default!

Save Configuration
The menu command File > CONFIGURATION > Save Con
X32/X52 parameters to the currently loaded configuration fil
$HOME/.xemu/3270.cfg or $HOME/.xemu/5250.cfg for stan
/setup/xemu/3270.cfg or /setup/xemu/5250.cfg for an eLux p
X32
configuration
commands
figuration 
e, for exam
d alone or 
lug-in.
Refresh button
14

allows you to save the
ple,
the default
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Save Configuration As
Stand alone: The menu command File > CONFIGURATION > Save as allows you to save the
settings to a new configuration file. Enter the name of the configuration file in the Save
Configuration dialog box. You must enter the extension “.cfg”.

ELux plug-in: The path must be the default /setup/xemu.

4.2 Connection Parameters

Connection Name
Before connecting to a host, you must define a name for the connection. All connections with
the relating parameters are saved in the file 3270.tcp/5250.tcp by their names. The connection
parameter file name (3270.tcp/5250.tcp) cannot be changed.

Connection Parameters
To change the parameters of a connection or to start a certain connection, use the
Connection Parameter TCP dialog box.

! To define parameters for a new connection:

1. Use the menu command File > Connection > Parameter to open the Connection
Parameter dialog box.

2. Click Edit to open the Connection Parameter TCP dialog box.

Connection
commands

1

2
3

To save
changes, click

1 Apply
2 Save
3 OK
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3. In the Connection Parameter TCP dialog box enter the following:

Connection name Enter an arbitrary name for the connection.

Host name Enter the name of the LAN channel adapter or a similar system.
Enter the IP address only if the name is not known.

Port host Enter the port number at which the host can be reached. Use
23 unless otherwise configured.

Terminal type Click to select the type of emulation. See section 8.1 Screen
Size, for information on the different screen sizes and 7.2
Troubleshooting for information on resolving screen distortion.
Note that for terminal types with the extension “-E”, the
Telnet E checkbox must be selected.

LU name X32: Enter the LU name as provided by your host administrator.

X52: Enter the device description as provided by your host
administrator.

Telnet E Click to select for the extended telnet protocol.

If you are uncertain what a parameter should be, ask your OS390/AS400 system
administrator.

4. Click Apply, Save and OK.

Apply transfers the settings made on the right-hand side of the dialog box to the connection
list on the left-hand side, identifying them by connection name. Save saves your connection
modifications to the file 3270.tcp/5250.tcp.

To remove a connection, in the Connection Parameter TCP dialog box select the connection
name and click Delete. Click Save to save the changes and then OK.

Restoring Previous Settings
The menu command File > Connection > Load loads the connection parameters and
overwrites the current connection parameters. This allows you to restore the original settings if
connection parameters were modified but not saved.

4.3 Session Parameters

These settings define data relevant to a session. To adjust the session
parameters, use the menu command File > SESSION > Parameter to
open the Session Parameter dialog box.
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Automatically connect Select this check box to
automatically start a session when
X32/X52 starts using the
connection entered in Connection
Name.

Show connection name Select this check box to display the
connection name in the system bar
when connected to a host.

Trimodal keyboard Select this check box to support
the K235 keyboard.

Character Set Select the character set from the
drop-down list to display special
characters such as ñ, ü, ä, ö, [, etc.
The default is ASCII.

Session Name The text entered in this box is
displayed in the title bar.

Connection Name Enter one of the connection
parameter configurations you
defined in section 4.2 Connection Parameters. To select a
connection parameter configuration, place the cursor in the box
and press any key. This opens the Connection Parameter dialog
box. Select the desired connection parameter configuration and
click OK in the Connection Parameter dialog box. Your selection
is entered automatically.

To save your changes permanently, the X32/X52 configuration file must be saved using the
menu command File > CONFIGURATION > Save. The Trimodal keyboard and Character
Set session parameters must be configured before you open a connection to take effect.

4.4 Connecting
There are several different ways to establish a connection.

Mouse In the status bar, double-click with the left mouse button on the red
color box. This connects using the currently defined connection
parameters.

Menu Use the menu command File > Connection > Connect or File >
Connection > Parameter. This opens the Connection
Parameters dialog box, which lists all currently defined connection
names. Select a defined connection and click Connect.

Keyboard Press CTRL-C. Note: You must have entered a connection name
in the session parameter (File > SESSION > Parameter >
Connection Name) as described in section 4.3 Session
Parameters and saved the configuration (File > CONFIGURATION
> Save).

When a connection has been established, the status bar color box is green.

4.5 Disconnecting
There are several different ways to disconnect:

Mouse In the status bar, double-click with the left mouse button on the
green color box.

Menu Use the menu command File > Connection > Disconnect.

Keyboard Press CTRL-D.

When a connection has been disconnected, the status bar color box is red.
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5 Programming Key Functions
This chapter describes how to program the P keys, B keys and keyboard mapping.

Section Description

5.1 Programmable Keys (P

Keys)

How to edit, load and save P keys using the P Key Editor

5.2 User Keys (B Keys) How to edit, load and save B keys using the B Key Editor

5.3 Keyboard Mapping How to map keyboard functions using the integrated

keyboard compiler

5.4 Keyboard How to release IBM functions
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5.1 Programmable Keys (P Keys)
X32/X52 offers 20 programmable keys (the so-called “P keys,” P1 to P20) that can be easily
mapped using the P Key Editor.

In addition, the emulation offers an additional 20 user keys (the so-called “B keys,” B1 to B20)
that can be easily mapped using the B Key Editor (see section 5.2 User Keys (B Keys)).

Use the menu command P Keys > Load / Save to load or save P key mapping files (*.pt).

Loading P Keys

From X32/X52, use the menu command P Keys > Load to load P key mappings. The file
has the extension ".pt".

Saving P Keys

From X32/X52, use the menu command P Keys > Save to save a P key mapping file.
You must enter the extension “.pt”.

Stand-alone: The default path is $HOME/.xemu.

ELux plug-in: The default path is /setup/xemu. The path must be the default!

P Key Editor
Use the menu command P Keys > Edit to open the P Key Editor. The
currently defined P keys are shown.

The P Key Editor offers two modes: View and Edit. The mode you are
in is shown in the lower border.

P key column

View / Edit mode
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View Mode

To enter View mode, in the P Key Editor:

•  click with the left mouse button on a P key in the P key column

•  or press the corresponding P key on the keyboard.

The cursor jumps to the P key line, but the line is not highlighted.

In View mode you can place the cursor anywhere within the keyboard mapping and delete
single characters. Cursor right and cursor left (" !) move the cursor within the current
keyboard mapping. Single characters may be deleted by delete key (DEL).

Edit Mode

To enter Edit mode, in the P Key Editor:

•  double-click with the left mouse button on a P key in the P key column

•  or press the corresponding P key on the keyboard twice.

If you are already in the View mode, enter Edit mode with another left mouse click on the P
key or pressing the P key on the keyboard again, or by means of the Insert function. (INS key)

In Edit mode, any key you press is added to the P key mapping. From within the P Key Editor,
the Keyboard menu allows you to map IBM functions to a P key.

Each P key can save up to 512 characters. If you wish to extend this limit, the last character in
a P key may be another P key to continue the first.

Return to View mode by clicking the P key again or by clicking on a different P key.

Loading P Keys

From within the P Key Editor, use the menu command File > Load to load P key mappings.
This is equivalent to the X32/X52 main menu command P Keys > Load. A P keys file has the
extension ".pt".

Saving P Keys

From within the P Key Editor, use the menu command File
> Save to save a P key mapping file. This is equivalent to
the X32/X52 main menu command P Keys > Save. You
must enter the extension “.pt”.

Stand-alone: The default path is $HOME/.xemu.

ELux plug-in: The default path is /setup/xemu. The path
must be the default!

Activating Changes for the Current Session

To exit the P Key Editor, click Cancel to discard changes or OK to activa
When you click OK, the keyboard mapping is valid for the current sessio
changes permanently, use the menu command File > Save from within 
X32/X52 main menu command P Keys > Save.

Enter file name
with extension “pt“
Refresh button
20

te the changes.
n. To save the
the P Key Editor or the
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5.2 User Keys (B Keys)
The B-keys represent 20 additional P keys that can be mapped arbitrarily by the user and
saved in files with the extension “.bt“.

B Key Editor
Use the menu command Add-On > User keys > Edit to
open the B Key Editor. The currently defined B keys are
shown.

The B Key Editor offers two modes: View and Edit. The
mode you are in is shown in the lower border.

B keys are programmed and used identically as P keys. Using the B Key Editor is identical to
using the P Key Editor (see section 5.1 Programmable Keys (P Keys)).

As is true for P keys, at any time B keys can be loaded (Add-On > User keys > Load ) or
saved to files (Add-On > User keys > Save ). When saving, you must enter the extension
“.bt”.

Stand-alone: The default path is $HOME/.xemu.

ELux plug-in: The default path is /setup/xemu. The path must be the default!

B key column

View / Edit mode
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5.3 Keyboard Mapping
The integrated keyboard compiler enables you to edit keyboard
functions comfortably and administrate these as keyboard
mapping files (*.kbd).

! To map a key combination to a function:

1. Use the menu command Add-On > Keyboard to open the Keyboard Compiler
dialog box.

2. Select the desired function (for example, “Field mark“) from the scroll-down list on the
left-hand side of the dialog box. The right-hand side of the dialog box displays the
corresponding key mapping (“Shift+3270_FieldMark“). No text appears if no key
combination is assigned to this function.

3. Click Enter key. The text “Press shortcut” appears in the dialog box.

4. Press the combination of keys (shortcut) you want mapped to the function. The
shortcut is displayed below “Enter Key”.

5. Click OK.

Local Functions
The following local functions must be mapped before they can be used.

Menu On/Off

Toggle that displays the main menu (File, Edit, Keyboard, P Keys, Add-Ons, ? Help).

Crosshair

Toggle that displays the crosshair. See 6.2 Cursor Options for information on configuring
crosshair settings.

By default, for trimodal keyboards crosshair is mapped to the LINE key.
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Hard Copy

Prints a hard copy using current printer settings. By default, hard copy is mapped to the
PRINT key. See 6.4 Printing for information on configuring printer settings.

In addition, the keyboard compiler contains the following:

Show: Displays the entire key mapping list, which can be printed.

Delete: Erases the shortcut mapped to the currently selected function. Note:
No confirmation box appears!

Load: Opens the Keyboard File Load dialog box, which allows you to
choose the path and file name of a keyboard mapping file (*.kbd).
When a keyboard mapping file is loaded, the mapping is activated
within the emulation immediately. To assign a new key mapping to the
emulation’s configuration, the configuration must be saved using the
menu command File > CONFIGURATION > Save.

Save: Saves the current keyboard mapping to a keyboard mapping file.
Note: You must enter the extension “.kbd”.

Stand-alone: The default path is $HOME/.xemu.

ELux plug-in: The default path is /setup/xemu. The path must be the
default!

5.4 Keyboard
When a key mapping is unknown, we recommend you use the
menu command Add-On > Keyboard to release the IBM
function.

Use the left mouse button to navigate through the
hierarchically organized Keyboard menu. To release a IBM
function, click on it with the mouse.



X32 – X52

24

6 X32/X52 Functionality
This chapter describes the different features and settings of X32/X52.

Section Description

6.1 Copy and Paste How to copy and insert text

6.2 Cursor Options How to set cursor and crosshair options

6.3 Colors How to edit the foreground and background color files

6.4 Printing How to print to a file, a local hard copy, hard copies, and

the screen

6.5 Fonts How to change the font size dynamically

6.6 ? Help Menu How to use the help and emulation information functions

6.7 Resource File How to set the value of certain parameters using the

resource file
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6.1 Copy and Paste
Note This feature is available only when the emulation is connected to a host.

This function allows you to copy data from the emulation screen (for example, article number)
and insert it at another screen position or later in the work session.

! To copy and insert text

1. Use the left mouse button to select the desired text.

2. From the Edit menu, click Copy.

3. Move the cursor to the position you want to insert the text.

4. From the Edit menu, click Paste. The text is inserted, as long as the application mask
permits this.

You can repeat the insertion procedure as often as you like.

6.2 Cursor Options

Cursor
Use the menu command Add-On > Cursor Options to open
the Cursor Options dialog box. You can choose from two
forms, a block rectangle or a line. You can also set the cursor to
blink.

Crosshair
To use the crosshair function, the crosshair display control character must be mapped to a
key.

! To map crosshair to a key

1. Use the menu command Add-On > Keyboard to open the Keyboard Compiler.

2. Select Crosshair from the left-hand window (may have to scroll down).

3. Click Enter key. The text “Press shortcut“ appears.

4. Press a shortcut key. The text appears on the right-hand side. Click OK.

Trimodal keyboard: By default, crosshair is mapped to the LINE key.

Cursor settings
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! To set the crosshair form

1. Use the menu command Add-On > Cursor Options to open the Cursor Options
dialog box.

2. Select the crosshair form you want: horizontal line, vertical line
or cross. Click OK.

3. In the worksheet, press the crosshair key shortcut. The
crosshair is activated.

4. Type text. The crosshair does not move.

5. To deactivate the crosshair, press the crosshair shortcut key
again.

Alternatively, select Cursor follows from the Cursor Options
dialog to have the crosshair move with the cursor.

To save cursor/crosshair settings, the configuration must be saved using the menu command
File > CONFIGURATION > Save.

6.3 Colors
Use the menu command Add-On → Colors to edit the
foreground and background color files (*.frb) using the Color
Setup dialog box. This dialog box allows you to assign the
foreground and background colors for the individual display
control characters.

Select the required field combination in the list on the left-hand
side and assign the foreground and background color. The
colors are mapped immediately on the emulation screen.

Attribute Function

Crosshair settings

Attribute button
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Required path for
eLux plug-in!

X32/X52 provides a useful automatic color attribute finder for when the field combination is
unknown.

! To use the automatic attribute finder function

1. Click Attribute. The Color Setup dialog box is hidden.

2. Move the mouse over text (do not click with the mouse!). The field combination
currently assigned to the text is displayed in the system bar (bottom of the screen).

3. Click on text with the mouse. The Color Setup dialog box reappears and the field
combination is automatically highlighted so it can easily be modified.

“Cursor” and “Selection” (selecting an area of text with the cursor for the copy
function) cannot be reached using the color attribute finder. In this case, map them
directly in the Color Setup.

Color mapping is administrated in an *.frb file, which you
can load, modify or save at any time. When saving a color
file, you must enter the extension “.frb”.

Stand alone: The default path is $HOME/.xemu.

ELux plug-in: The default path is /setup/xemu. The path
must be the default!

If the name of the color file has changed, the X32/X52
configuration file must be saved using the menu command
File > CONFIGURATION > Save.

6.4 Printing

Printer Setup
In X32/X52, you can print local hard copies using the menu
command Add-On > Printer as well as hard copies. This opens
the Printer Setup.
Refresh button
27
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File Defines the output device. Click to select this checkbox to print to a
file. See “Extended file” and “Output file” below.

Printer Defines the output device. Click to select this checkbox to print to a
printer.

Page break Adds FF (form feed) to page end.

Extended file When this checkbox is selected, when printing to a file the data is
appended. Otherwise the file is truncated.

Printer Device Displays a list of all known UNIX printers. Choose one.

Character Set Displays a list of all character sets supported by the printer.
Choose one.

CR >>>>>>>> CR + LF The character CR (carriage return) will be converted into the
characters CR and LF (line feed).

CR >>>>>>>> LF + CR The character CR (carriage return) will be converted into the
characters LF (line feed) and CR.

CR >>>>>>>> CR The character CR (carriage return) will not be changed.

Ignore DEL The character DEL will not be transmitted to the output device.

Output file Name of the output file, if the File checkbox has been selected
above.

Stand alone: By default, the file is saved to
$HOME/.xemu/hardcopy.lp.

ELux plug-in: By default, the file is saved to
/setup/xemu/hardcopy.lp.

Note Do not enter a path! The file must be printed to the default
path. Do not use /tmp/<file path>!

PRINT Key Mapping
By default, the local function “hard copy” is mapped to the PRINT key (see5.3 Keyboard
Mapping). Printer settings must be configured before using the key.

Print Screen

Note This feature is available only when the emulation is
connected to a host.

Use the menu command Add-On > Print Screen to print a hard
copy of the worksheet. Printer settings must have been
configured previously. See 6.4 Printing.

Keyboard shortcut: CTRL – P.



X32 – X52

29

6.5 Fonts
By default, X32/X52 provides seven different font sizes. Use the
menu command Add-On > Fonts to open the Define Fonts
dialog box and change the font size dynamically.

When a font size is selected, the main
screen size automatically adjusts to allow
you to preview your selection. Click OK to
assign the font size to X32/X52. To save
your changes to the X32/X52
configuration file, use the menu command
File > CONFIGURATION > Save.

The full screen width button  in the title
bar (upper right corner) toggles between
full screen and the font width set in fonts
(see Title Bar, page 4). In full screen
mode, the font size

 is set automatically.

6.6 ? Help Menu
Help

Clicking ? > Help starts the Netscape browser and points you to the UniCon
documentation page (www.myelux.com). Here you can find a pdf version of the
X32/X52 manual.

Info

Clicking ? > Info displays the starting pop-up box which contains version information and
release date.

6.7 Resource File
X32/X52 uses a resource file. In the resource file you can:

•  enable/disable menus

•  turn off the starting pop-up dialog box

•  set the tone (beep)

ELux plug-in: The resource file is “Xdefaults” and located in the /setup area on the Thin Client.
It can only be created using the Scout eL management tool.

! To modify the resource file (eLux plug-in)

1. Open the resource file “Xdefaults” located in the Scout eL directory using a UNIX
editor (for example, PFE32, included on your eLux CD).

2. Make the desired changes.

3. Transfer the resource file to the desired number of Thin Clients using the Scout eL
“File List” function. See the Scout eL Administrator’s Manual for more information.
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You can use the system resource file located on the Thin Client as a template. It is located in:

/usr/X11R6/lib/X11/app-defaults/X32 : X32

/usr/X11R6/lib/X11/app-defaults/X52 : X52

Open a copy using a UNIX editor and make the desired changes. Do not edit text after the line
“Do not edit below this line!”

Note When using the system resource file as a template for the emulation resource file, text
below “Do not edit below this line” should not be changed!

Stand-Alone: The resource file is $HOME/.Xdefaults and must be edited with a UNIX editor.

Following are several examples of X32 parameters.

Enabling/Disabling Menus

The first entries in the file are for menu operation and can be used to disable specific menus.
For example, to disable the File menu:

! Menue File

x32.X32.appform.titlebar.datei.sensitive: False

Note Disabling a menu disables all menu commands contained in that menu. If you disable
the File menu, the menu command Close is also disabled and the emulation can no longer be
shut down!

Turning off the starting pop-up dialog box

When you first start the emulation, a dialog box appears on the screen with the version
number and release date. To turn off the starting pop-up dialog box, set:

X32.infobox: False

Setting tone

To set the beep values:

X32.volume: 60 : Volume. Allowed values: 0 to 100

X32.tone: 2000 : Frequency (in Hertz)

X32.time: 300 : Length (in milliseconds)

Setting Parameters for X52

X32 and X52 parameters are defined in the same Xdefaults file. To define X52 parameters,
replace “x32” with “x52” in the examples above.

! Menue File : Enabling/Disabling Menus

x52.X52.appform.titlebar.datei.sensitive: False

X52.infobox: False : Turning off the starting pop-up dialog box

X52.volume: 60 : Setting tone

X52.tone: 2000

X52.time: 300
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7 Troubleshooting

7.1 Diagnosis

The data transfer between X32/X52 and OS390/AS400 can be traced
and saved to diagnosis files.

Use the menu command File > Diagnosis to switch the data trace on
and off.

The files are numbered and saved in the folder /tmp. The files are named
X32.<number> or X52.<number>, where <number> begins with “000”.
Before you switch on the diagnosis you should delete all files with this
name.

When the trace is finished, the diagnosis function must be deactivated.

ELux plug-in: The emulation menu command Diagnosis creates the trace files. The eLux
starter can be used to send these trace files to the destination of your choice (Setup >
Diagnostics > X-Emulation files).

7.2 Screen
X32, Stand Alone and Plug-In

If you change the terminal type during an X32 session and continue working, you may
experience screen distortion. To avoid this, when changing terminal type use the following
procedure:

! To change terminal type in X32

1. Open the Connection Parameter TCP dialog box using the menu command File >
CONFIGURATION > Connection > Parameter > Edit > Terminal Type. Change the
terminal type. Click Apply > Save > OK.

Terminal type

1

2
3

To save
changes, click

1 Apply
2 Save
3 OK
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2. Save your changes to the X32 configuration file by using the menu command File >
CONFIGURATION > Save.

3. Restart the emulation! Screen size settings are sent to the host when the emulation
starts. Different emulation types have different screen sizes. If you continue to work
and do not restart, you may experience screen distortions.

See 8.1 Screen Size for the different screen sizes and terminal types.

X52, Stand Alone and Plug-In

It is not necessary to restart the X52 emulation when you change the terminal type in the
Connection Parameters TCP dialog box during a session. However, you must click Apply >
Save > OK and you must disconnect and reconnect.

7.3 Save Configuration File As
X32/X52, Plug-In

As an eLux plug-in, by default the required configuration file path must be /setup/xemu! (This
is not true for the stand-alone program.) This is due to flash size constraints on the Thin Client.
If you try to save configuration files to other directories, they will not be saved. No error
message will be displayed.
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8 Appendix

8.1 Screen Size
The Connection Parameter TCP dialog box offers several terminal types with different
extensions. Different extensions have a different number of lines and columns in the emulation
screen. The values are given below.

3270

Terminal types 3278, 3279

Extension Lines x Columns

-2 24 x 80

-3 32 x 80

-4 43 x 80

5250

All terminal types are 24 x 80 except for:

Terminal Type Lines x Columns

3477-FC 27 x 132

3477-FG 27 x 132

3180-2 27 x 132
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9 I N D E X

A

abbreviations ∙ 5

about

manual ∙ 4

X32/X52 ∙ 6

automatically connect ∙ 17

B

B keys

about ∙ 21

editor

about ∙ 21

loading ∙ 21

saving ∙ 21

loading ∙ 21

saving ∙ 21

background color ∙ 26

C

CD-ROM, documentation ∙ 5

character set

keyboard ∙ 17

printing ∙ 28

closing X32/X52 ∙ 10

color box, system bar

meaning of colors ∙ 10

using to connect ∙ 17

using to disconnect ∙ 17

colors, setting ∙ 26

configuration file

about ∙ 14

opening ∙ 14

saving ∙ 14

saving as ∙ 15

what must contain ∙ 14

connecting

via color box ∙ 17

via keyboard ∙ 17

via menu ∙ 17

connection name

connection parameters ∙ 15

displaying in system bar ∙ 10, 17

entering in session parameters ∙ 17

connection parameters

configuring ∙ 15

connection name ∙ 15

restoring previous settings ∙ 16

conventions used in manual ∙ 4

copying ∙ 25

crosshair options ∙ 25

cursor options ∙ 25

cursor position, show in status line ∙ 10

D

diagnosing ∙ 31

disconnecting

via color box ∙ 17

via keyboard ∙ 17

via menu ∙ 17

display

fonts ∙ 29

main window ∙ 9

F

features, X32/X52 ∙ 6

fonts, changing ∙ 29

foreground color ∙ 26

H

hard copy, printing ∙ 27

help, information on X32/X52 ∙ 5

I

installing

Felics license server ∙ 8

X32/X52

as eLux plug-in   See ∙ eLux Administrator’s

Manual



X32 – X52

35

as stand-alone program ∙ 8

K

keyboard

mapping ∙ 22

releasing IBM functions ∙ 23

trimodal ∙ 17

keyboard window ∙ 9

L

licensing

entering local license key ∙ 12

using without license ∙ 12

via Scout eL management tool ∙ 12

local hard copy, printing ∙ 27

M

main menu

about ∙ 9

copying and pasting ∙ 25

main window ∙ 9

mapping keyboard ∙ 22

menu, about ∙ 9

N

NILS ∙ 10

P

P keys

editor

about ∙ 19

Edit mode ∙ 20

loading ∙ 20

saving ∙ 20

View mode ∙ 20

loading ∙ 19

saving ∙ 19

pasting ∙ 25

printing

choosing character set ∙ 28

configuring settings ∙ 27

hard copies ∙ 27

printing (continued)

local hard copies ∙ 27

page break ∙ 28

print screen ∙ 28

to file ∙ 27, 28

R

releasing IBM functions ∙ 23

removing X32/X52 ∙ 8

requirements, system ∙ 8

restoring previous connection settings ∙ 16

S

session name

displaying in title bar ∙ 9, 17

setting ∙ 17

session parameters

about ∙ 16

automatically connect ∙ 17

character set ∙ 17

displaying connection name in system bar ∙ 17

entering connection name ∙ 17

setting session name ∙ 17

trimodal keyboard ∙ 17

starting X32/X52 ∙ 8

status line ∙ 10

system bar

about ∙ 10

connection name ∙ 17

system requirements ∙ 8

T

title bar, about ∙ 9

trimodal keyboard, setting ∙ 17

troubleshooting   See ∙ diagnosing

U

user keys   See ∙ B keys

W

window

keyboard ∙ 9



X32 – X52

36

main ∙ 9

work area   See ∙ worksheet

worksheet ∙ 10

copy and paste ∙ 25

fonts ∙ 29

X

X32/X52

X32/X52 (continued)

about ∙ 6

closing ∙ 10

features ∙ 6

removing ∙ 8

starting ∙ 8

system requirements ∙ 8
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