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Preface

We want to thank you for choosing the UniCon products and assure you that
UniCon communication software combines best functionality with a maximum
of user comfort.

This detailed technical description will help you in getting used to work with the
product. However, questions will still arise especially when communication
components of other producers are also being used. In this case please
contact us immediately. We will give you qualified support.
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1 X97 for Scovery

1.1 Main Window

Starting the X97 emulation shows the main window of the emulation which
contains the following elements:

Titelzeile

Sessionname

Hauptmenü

Tastaturfenster

Arbeitsbereich

Statuszeile

Systemzeile

Cursor-PositionLeitungsstatus

Verbindungsname UhrzeitAmpelfeld

Fig. 1: X97-Main Window

Main Menu
You get the functions of the main menu by a left mouse click or the
corresponding key (e.g. ALT F for „File“).

Worksheet

By a left mouse click you can move the cursor at any position the application
mask allows.
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Keyboard Window
The displayed keys correspond to the 9750 terminal keyboard and can be
activated directly by a left mouse click. The keyboard is shown if the option
„AddOns → Keyboard window“ has been activated.

Status Line
The status line informs, among others, about the line status (LTG, POLL) and
the state of transaction (DIA, SAN, DUE). The address (Format: yyxx) of the
cursor position is shown, if the option „AddOns → show Cursor Position“ has
been activated.

System bar
This line shows the existing connection name. The color box shows the state
of the connection.

•  red no connection
•  yellow trying to connect
•  green connection established

By a left double mouse click into the color box you can connect or disconnect.
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1.2 Configuration

The X97 administrates all session data in a configuration file (by default this is
$HOME/.xemu/default.cfg). This allows to adjust the view and the behaviour of
the emulation to your individual priorities and requirements as well as activate
the start parameters. Among others, a configuration file contains:
•  general session parameter
•  link to a color file (e.g. default.frb)
•  link to a keyboard file (e.g. default.kbd)
•  link to a connection from the connection file conhost.tcp
•  link to user keys (e.g. heinz.bt)
•  link to P keys (e.g. heinz.pt)

1.2.1 Open Configuration
To open a new configuration file, select the menu command „File → Open
Configuration“.

The dialog box offers you to choose the configuration file you prefer. Loading
the new configuration will delete the existing X97 settings and abort any
existing connection.

1.2.2 Save Configuration

Fig. 2: Main Menu „File“
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The menu command „File → Save Configuration“ allows you to save the
configuration, so that the X97 parameters are saved into the currently loaded
configuration file (e.g. $HOME/.xemu/default.cfg).

1.2.3 Save Configuration as...
The menu command „File → Save configuration as ...“ allows you to save the
settings into a new configuration file. Enter the path and name of the
configuration file into the dialog box.
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1.3 Connections

Before connecting to a partner, a name must be defined for this connection.
All connections with the relating parameters are saved in the file conhost.tcp
by their names.

1.3.1 Connection Parameters
To change the parameters of a connection or to start a certain connection,
select the menu command „File → Connection →Parameter..“. First you get a
list of all connection names which have been registered. Choose [Connect], in
order to activate the required connection, or [Edit], in order to define or to
modify a connection.

In the dialog box you can easily change the following connection parameters:
•  Connection Name is an arbitrary name and identifies the connection
•  Host Name is the name of the LAN channel adapter or a similar system

(e.g. BS2000). If you don’t know the name, you may enter the IP address
instead.

•  Port Host is the port number being addressed at the host. If not
configured otherwise, use 102.

•  Application is the host application you want to connect to(e.g. $DIALOG).

Fig. 3: Connection parameter
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•  Station is the station name as defined for your workstation by the host.
The station name must be unique for each emulation server.

If you are uncertain as to what the contents should be, ask your BS2000
system administrator.

Having entered the parameters please select [Apply]. Thus the settings
identified by the connection name are added to the connection list. If you wish
to save the modifications select [Save]. This saves your connections into the
file conhost.tcp.
The function [Delete] allows to remove connections. Here, too, you should
select [Save] , in order to save the changes.

1.3.2 Connect
There are different ways to establish a connection:
1. The menu function „File → Connection → connect“ provides the

connection defined for the current session.
2. Double-clicking the left mouse button into the red color box will connect

you according to the currently defined connection parameters. The color
box will then change from RED to GREEN.

3. Press the corresponding connect key (CTRL-C).
4. The menu function „File → Connection → Parameter → Connect“ allows to

choose any defined connection and start it.

1.3.3 Disconnect
There are different ways to disconnect as well:
1. The menu function „File → Connection → disconnect“.
2. Double-clicking the left mouse button into the green color box will

disconnect the currently defined connection. The color box will then
change from GREEN to RED.

3. Press the corresponding Disconnect key (CTRL-D).

1.3.4 Load Connection
By means of the function „File → Connection → load“ the connection
parameters are loaded from the file conhost.tcp. This overwrites the current
connection parameters. Thus, you can restore the original settings, if
connection parameters have been modified, but not been saved yet.

1.4 Session Parameters

These settings define several data relevant to a session. Select the function
„File → Session Parameter“ and adjust the parameters, if necessary.
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Automatic Connection
This option allows to establish the connection, which has been preset for this
session, automatically during X97 start.

FBZ=ASZ
In this display mode the X97 generates the display control characters (ASZ)
from field handling characters (FBZ). The mode is used by certain host
applications. The allocation may be controlled by ASZ setup „AddOns → ASZ
control“. (cf chapter „AddOn-functions – ASZ control).

Connection in System Bar
The name of the connection is displayed in the system bar.

Fig. 4: Session Parameter
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Character Set
Please select the option „German“ if special characters (ü,ä,ö,…) are to be
displayed, otherwise the corresponding English characters are shown.

Session Name
You may name your session by a self-explanatory name, which will be shown
in the title bar.

Connection Name
This option defines the currently used connection. In order to select a
connection, press any key in this box  and select the desired connection (cf
chapter „Connections“).
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1.5 Keyboard

The integrated keyboard compiler enables you to edit keyboard functions
comfortably and administrate these as files (*.kbd). Select the function
„AddOns → Keyboard“:

Select the desired function (e.g. „Remove line“) in the function list (left part).
The right part of the dialog box shows the corresponding key mapping
(„Shift+Delete“).

Delete
If you want to erase the mapped key, select [Delete].

Key Mapping
In order to map the function to a new key, select [Key mapping]. You are then
requested to press a combination of keys, which is then displayed and
mapped to the function. If this key combination (shortcut) had already been
assigned to another function, you get a message and, if you want, the earlier
mapping may be deleted.

Show Key Mapping
The entire key mapping is shown by a mapping list and can be printed, too.

Load/Save
A keyboard mapping may be loaded or saved. When loaded the mapping is
activated within the X97 immediately. In order to assign a new key mapping

Fig. 5: Keyboard-Compiler
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into the X97 configuration, the configuration must be saved (cf chapter
“Configuration”).
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1.6 Colors

The color setup allows to assign the Anzeigesteuerzeichen (ASZ) individually
to foreground and background color of the workspace. You find the the color
setup in the menu „AddOns → Colors“:

Select the required ASZ combination in the list on the left side and assign the
foreground and background color. The colors are mapped immediately on the
emulation screen.
Should the ASZ combination be unknown, select [attribute]. The color setup
then temporarily disappears, and you may select the required field on the
emulation screen by a left mouse click. Moving the mouse pointer across the
screen, the ASZ is shown in the System bar wih its position. Selecting it will
show the color dialog box again, the corresponding ASZ combination is
highlighted and may now be colored.

The color mapping is administrated in a file (*.frb) and may be loaded,
modified and saved any time. In order to add the colors to the X97
configuration file, this file must be saved before (cf chapter “Configuration”).

Fig. 6: Colors
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1.7 P Keys

The X97 offers an efficient editor which allows you to edit the programmable
keys P1 – P 20. Normally the mapping of the so-called P keys is controlled by
the host application. In this case you may still define the user keys for your
personal use (cf chapter „User Keys“).
The P key mapping may be loaded  or saved via the main X97 menu („P Keys
→ Load“) and („P keys → Save“) . To start the P Key editor, select „P keys →
Edit“ in the main X97 menu. The presently defined P keys are shown.

If the programming of la P key should have been locked by the application, the
key is marked by „DVA“ on the left margin.

Edit P Keys
The P key editor offers 2 modes: display and edit. The mode you are in is
shown at the bottom line of the screen. (Display / Edit).

By mouse click or the corresponding P key any P key can be directly pointed
at. Then you are in the display mode of the key.

Display mode:
This mode allows you to place the cursor anywhere within the keyboard
mapping and delete single characters. The mode is activated when the P key

Fig. 7: P Key Editor, Display
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has been selected (by a left mouse click or pressing the P key on the
keyboard). SMR (Cursor right) and SML (Cursor left) moves the cursor within
the current keyboard mapping. Single characters may be deleted by AFG
(Delete), LZF removes the contents starting from the cursor position.

Edit Mode:
You get into this mode by another left mouse click on the P key in the display
mode (or pressing the P key on the keyboard again), and also by means of
the EFG function. In this mode any key you press is added to the P key
mapping. The menu „Keyboard“ allows you to program Siemens functions into
a P key by menu commands.

Fig. 8: P Key Editor, Edit Mode

Each P key may save up to 512 characters. If you wish to extend this limit, the
last character in a P key may be another P key to continue the first.

By activating the P key again or by clicking on a different P key you return to
the display mode.

Load P Keys
Starting from the P Key Editor P key mappings may be loaded by the function
 „File → Load“. the X97 main menu offers the function „P keys → Load“ .
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Save P Keys
To save a P key mapping please select „File → Save“ in the editor or „P keys
→ Save“ from the X97 main menu. The file has the extension ".pt" .

When you want to leave the editor, select [OK], in order to save the changes,
or [Cancel] to discard them. Thus the key mapping in the current X97 session
is valid.
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1.8 User- Keys (B Keys)

Since the 20 P keys set for the SIEMENS terminals (cf chapter „P keys“) or
assigned by the host application often are insufficient, the user may define his
own keys, the so-called B keys. Thus we provide for another 20 P keys, which
may be mapped arbitrarily by the user and are saved in files with the
extension „.bt“. Start the B key editor via the menu „AddOns → user-keys →
Edit“:

The user-defined keys do not differ from the P keys as for programming and
use. (cf chapter „P Keys“).

Just like P keys the B keys may be loaded any time („AddOns → User-keys →
Load“ ) or saved  („AddOns → User-keys → Save“).

Fig. 9: User-defined Keys
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1.9 AddOn Functions

1.9.1 Cut and Paste (Cut and Paste)

This function allows to copy any data from the emulations screen (e.g. article
number) which may be inserted at any other position and time. To do this,
select the desired screen area (keep left mouse button pressed), and then
select the menu „Edit → Copy“ :

Then move the cursor to the position you want to insert the selected data at
and choose „Edit → Paste“. The data ara inserted, as far as the application
mask does allow this. The insert procedure may be repeated as often as you
need it.

Fig. 10: Cut and Paste
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1.9.2 Keyboard

Whenever a key mapping is unknown, it is best to use the menu command
„Keyboard“ to release a Siemens function, e.g. K1.

The left mouse button moves you to a hierarchically organised menu. To
release the desired Siemens function, just click the corresponding menu.

Fig. 11: Keyboard
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ASZ control
By means of the ASZ setup, which is to start by the menu  „AddOns → ASZ
control“ , you can control the generating of the display control characters
(ASZ) from the field handling characters (FBZ). However, these settings are
only relevant, if the host application uses the mode FBZ=ASZ and if this mode
has been activated in the X97. (cf chapter „Session Parameters - FBZ=ASZ“).

Select the desired field handling character (e.g. „Locked“) and further select
the requested corresponding display control character (e.g. „Light“). Leave the
dialog box by clicking [OK], if you want to assign the settings in the X97, or
click [Cancel] to discard the changes.

Save the configuration of the X97 („File → Save Configuration“), in order to
keep the defined settings permanently.

Fig. 12: ASZ Control
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1.9.3 Print

The X97 allows to print local hardcopies by the menu „AddOns → Hardcopy“
as well as by the print functions LA1-LA7. The current printer and the
corresponding options are registered in the print setup. Select „AddOns →
Printer“:

The options have the following effects:

File/Printer Defines the output device. If you want to print into a file,
please fill the box “Output file”.

SM to EM Only the area from cursor position up to the next end mark is
printed.

File attach The data are attached to the file when printed.

Printer Device List of all known Unix printers you must choose a printer
from.

Fig. 13: Print Setup
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Character Set Selection of the character set being supported by the printer.

CR >>>>>>>> CR+LF The character CR (Carriage Return) is split into the
characters CR and LF (Line Feed)..

CR >>>>>>>> LF+CR The character CR (Carriage Return) is split into the
characters LF (Line Feed).and CR.

 CR >>>>>>>> CR The character CR (Carriage Return) is not transmitted.

Ignore DEL The character DEL is not transmitted to the output device.

AusgabeFile Name of the output file, if an output device  „File“ has been
entered.
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1.9.4 Fonts

By default the X97 provides for 8 different font sizes, which may be changed
dynamically. The function „AddOns → Fonts“ leads you to the font setup
where you may define the desired font size.

Confirming the selection by [OK] assigns the font size to the X97, and the
emulation screen gets a new dimension.

Fig. 14: Font Selection
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1.9.5 Diagnosis

For the purpose of diagnosis the data transfer betwenn X97 and BS2000 may
be traced and saved in diagnosis files. By means of the function „File →
Diagnose“ the data trace may be switched on and off. The files are numbered
and saved in the folder /usr/u97/data. The files are named TR-<pid>.<nr> .
Before you switch on the diagnosis you should delete all files with this name.
When the trace is finished, the diagnosis function must be deactivated.
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